AppCompatのV21 :材料設計のアクションバー( ) InflateExceptionエラー-膨らまクラス

? user3871754 @ | Original: StackOverFlow

「 ____ 」新しいライブラリに( 「 ____ 」 )で行われたアプリを移動しよう

と: 「 ____ 「作業ナイス

i done this:

appcompat v20

and have this:

appcompat v21

http://stackoverflow.com/questions/21386077/error-inflating-class-android-support-v7-internal-widget-actionbarview



Top 5 Respuesta

1Gabriele Mariotti @

新しいを使用するためには「 ____ 」あなたがする必要があります:

extend the appcompat-v7:20 instead of ActionBarActivity implements ActionBar.TabListener, ActionBar.OnNavigationListener use android.view.InflateException: Binary XML file line #17: Error inflating class android.support.v7.internal.widget.ActionBarOverlayLayout instead of appcompat v21 use a theme which inherits from Theme.AppCompat.(for example Light or NoActionBar)

また、 ActionBar.TabListenerは、 ActionBar.OnNavigationListener :アクションバーのナビゲーションモードは非推奨とインラインツールバーのアクションバーでサポートされていません。代わりに他の一般的なナビゲーション·パターンを使用することを検討してください。

ソースドキュメント:  https://developer.android.com/reference/android/support/v7/app/ActionBar.html#addTab(android.support.v7.app.ActionBar.Tab)



2Vivek Shah @

これはcopmactv7_api5が使用して...コードが動作している...別の手順は同じです

ActionBarActivity
3user3871754 @

問題は、それが思われるよりもはるかに深かった。

私のコードは正しかった。該当すると正しい対象のすべてのアドバイス。

それは「 ____ 」とは、唯一のFragmentActivityをサポートしませんが、 「 ____ 」外部ライブラリは古いバージョンが含まれていることが判明

それは「 ____ 」の理由だった

すべての外部ライブラリでの更新は「 ____ 」の問題を解決します。

他のトピックの私のbuild.gradle :

http://stackoverflow.com/questions/26888089/multiple-dex-files-define-landroid-support-v4 。