Hello WorldのAndroidアプリ、エラー: workspaceappcompat_v7 esvalues ​​- v21styles_base.xmlはなしリソースはそれが与えられた名前と一致が見つからない

? Cliff @ | Original: StackOverFlow

私はちょうどAndroidの開発に入った完全に初心者です。私は「 ____ 」 」の公式Androidの開発者のWebページのチュートリアル。私はすべての命令に従っを通じてつもりですが、それは私にEclipseでこのエラーコードを示します。エラーメッセージが長い本物だと私は私の設定で何か間違っがなければならないと思い、 SDK 、または環境が。誰もがこの問題を解決する私を助けることはできますか?あなたの情報については、 「 ____ 」私のターゲットSDKは「 ____ 」であり、私もそれをコンパイルしています

"Building your first app


Top 5 Respuesta

1Trekker @

この場合に役立ちます参照してください:

In Eclipse, right click on current project, click on Import... then choose General > Existing Projects into Workspace. Use "Select root directory:" and browse for local folder containing "adt-bundle-windows" in pathname, which typically looks something like "C:Developmentadt-bundle-windows-x86_64-20140702sdkextrasandroidsupportv7appcompat". Select that appcompat folder. Under Projects:, android-support-v7-appcompat should be checked. IMPORTANT: Make sure "Copy projects into workspace" is also checked. Click finish. android-support-v7-appcompat project will appear under Package Explorer. Go to File > New > Android Application Project, create a new project and you'll see that appcompat_v7 now is built each time a new project is created. android-support-v7-appcompat project can be deleted now. After doing this, it'll stop working for the current project and errors will appear. Do this next... Right click on current project, go to Properties. Click on Android, then under Library click on Add... and select appcompat_v7 to associate with your current project. Remove android-support-v7-appcompat from the list. Now appcompat_v7 will appear as its own project in your workspace (and it'll probably fix the bin folder), and your current project should hopefully now work.

2Elenasys @

私たちは、新しいプロジェクトを作成するときに問題の原因が、それは「 ____ 」ライブラリの参照が含まれていますが見つかりました:

Hello WorldのAndroidアプリ、エラー: workspaceappcompat_v7
esvalues ​​- v21styles_base.xmlはなしリソースはそれが与えられた名前と一致が見つからない

「 ____ 」ライブラリには、すでにサポートライブラリ" " __ "を"が含まれている

Hello WorldのAndroidアプリ、エラー: workspaceappcompat_v7
esvalues ​​- v21styles_base.xmlはなしリソースはそれが与えられた名前と一致が見つからない

問題が作成された新規プロジェクトは「 ____ 」フォルダ、ライブラリ" " __ "に含まれていることです」あまりに!,だけ(つまり、すでに「 ____ 」ライブラリに含まれている)あなたの新しいプロジェクトからこのの.jarを削除

忘れるドントに「 ____ 」

3Muhammad Ebad @

あなたがしようとCA One葯の事は、対象ターゲット=アンドロイド-21をアンドロイド支援-V7 - AppCompatののproject.propertiesファイルを開き、変更することです(最新) 。 その後ちょうどプロジェクトん - >クリーンは...ように、変更が有効になります。

4Dodge @

あなたの情報については、私のターゲットSDKはAPI19であり、私もAPI19でそれをコンパイルしています

ターゲットに対してAPI21を使用してコンパイル。

API 19は不足している素材のものを知っているん。

5pokerface @

持ってAppCompatのV7 、のproject.propertiesファイルを更新します。 「 ____ 」から「 ____ 」

また、更新する「 ____ 」ライブラリ