新しいワークスペースにプロジェクトをビルド中にエラーガット

? Harikrishnan @ | Original: StackOverFlow

アンドロイド開発のための新しいです。私は、API 21としてターゲットSDKを使用して新しいワークスペースを作成しようとしたと私はAPI19と20のSDKとしないAndroid5がインストールされているAPI 19にコンパイルされた。私は、新しいワークスペースを作成し、それを作成した後に、プロジェクトをコンパイル中に、私は以下のエラーになってしまっている新しいプロジェクトを作成した。誰もがどのようにこのを取り除くために私を助けることはできますか?

Error details:



Top 5 Respuesta

1QArea @

あなたもアンドロイド4.4.2にプロジェクトのビルドターゲットを変更しましたか?

ここではみんなが同じ問題を抱えていた。 http://stackoverflow.com/a/14843198/3864698



2Muhammad Ebad @

あなたが試すことができる一つの葯の事はアンドロイド支援-V7 - AppCompatののproject.propertiesファイルを開き、ターゲットのターゲットを変更することです。そして、ちょうどプロジェクトを行う - >クリーン変更を有効にするよう。

3Andy Dent @

私はAndroidのツールをインストールし、誤ってAndroidのSDKマネージャで4.4Wと同様に4.4.2を選択したに新しい誰かと同様のエラーが発生しました。

これは、API 20がより新しいと思われる、新しいプロジェクトのデフォルトによってピックアップされることを意味し、両方のAPI 20とインストールされ、API 19を持つことになる。

ただし、API 20のみウェアラブルです。

あなたは4.4Wがパスに終わったことを「 __rsm__ 」でここに見ることができます。

appcompat_v7とHelloAndyプロジェクトの目標の両方がこのパスの問題を抱えていた。

私は( appcompat_v7やその他のプロジェクトを右クリックします)の両方のproject.propertiesを編集し、アンドロイド-20は、両方のプロジェクトに関する最新の情報に更新をしました=アンドロイド- 19を対象とする=ターゲットを変更しました。それは正しいのAndroid SDKを指すように、ビルド·パスを更新した。

4pokerface @

持ってAppCompatのV7 、のproject.propertiesファイルを更新します。 「 ____ 」から「 ____ 」

また、「 ____ 」ライブラリを更新(ことによって「 ____ 「私は」 ____ 」で更新を意味し、再輸入など)

5Adgaonker Shashank @

エラーは、あなたのプロジェクトをきれいに発見されたwhereeverちょうどそのスタイルの行を削除

そして、プロジェクト5.0が着果し作る

新しいワークスペースにプロジェクトをビルド中にエラーガット